VMware Security Announcement VMSA-2020-0022

Today VMware released a new security announcement VMSA-2020-0022. This announcement affects the VMware Horizon Client and addresses a denial-of-service vulnerability (CVE-2020-3991).

Impacted Products
  • VMware Horizon Client for Windows
Introduction

A denial-of-service vulnerability affecting VMware Horizon Client for Windows was privately reported to VMware. Updates are available to address this vulnerability in affected VMware product.

File system access control denial-of-service vulnerability (CVE-2020-3991)

Description

VMware Horizon Client for Windows contains a denial-of-service vulnerability due to a file system access control issue during install time. VMware has evaluated the severity of this issue to be in the Moderate severity range with a maximum CVSSv3 base score of 5.9.

Known Attack Vectors

Successful exploitation of this issue may allow an attacker to overwrite certain admin privileged files through a symbolic link attack at install time. This will result into a denial-of-service condition on the machine where Horizon Client for Windows is installed.

Resolution

To remediate this vulnerability in the Horizon Client for Windows 5.x and prior. Install version 5.5.0. Download links and release notes below.

References

Fixed Version(s) and Release Notes:

Horizon Client for Windows 5.5.0
Downloads and Documentation:
https://my.vmware.com/en/web/vmware/downloads/details?downloadGroup=CART21FQ3_WIN_550&productId=863&rPId=53321
https://docs.vmware.com/en/VMware-Horizon-Client/index.html