VMware Security Announcement VMSA-2021-0010 CVSSv3 score range 6.5 to 9.8 Critical!

A new security advisory just released by VMware, VMSA-2021-0010. This one affects VMware vCenter Server, the updates address remote code execution and authentication vulnerabilities (CVE-2021-21985, CVE-2021-21986). This needs your immediate attention if you are using vCenter Server!

Impacted Products
  • VMware vCenter Server (vCenter Server) 6.5 and later
  • VMware Cloud Foundation (Cloud Foundation)
Introduction

Multiple vulnerabilities in the vSphere Client (HTML5) were privately reported to VMware. Updates and workarounds are available to address these vulnerabilities in affected VMware products.

VMware vCenter Server updates address remote code execution vulnerability in the vSphere Client (CVE-2021-21985)

Description

The vSphere Client (HTML5) contains a remote code execution vulnerability due to lack of input validation in the Virtual SAN Health Check plug-in which is enabled by default in vCenter Server. VMware has evaluated the severity of this issue to be in the Critical severity range with a maximum CVSSv3 base score of 9.8.

Known Attack Vectors

A malicious actor with network access to port 443 may exploit this issue to execute commands with unrestricted privileges on the underlying operating system that hosts vCenter Server.

Workarounds

Please keep in mind that this is a temporary solution only!

A workaround is provided in the following article How to Disable VMware Plugins in vCenter Server (83829)

Resolution

For vCenter Server 7.0, patch to fixed version 7.0 U2b. Download and release note links will be provided below

For vCenter Server 6.7, patch to fixed version 6.7 U3n .  Download and release note links will be provided below

For vCenter Server 6.5, patch to fixed version 6.5 U3p. Download and release nots links will be provided below.

For Cloud Foundation (vCenter Server) 4.x, apply fixed version 4.2.1. Download and release note links will be provided below.

For Cloud Foundation (vCenter Server) 3.x, apply fixed version 3.10.2.1. Download and release note links will be provided below

There is also a great FAQ article on this advisory. Questions & Answers for VMSA-2021-0010 |

Authentication mechanism issue in vCenter Server Plug-ins (CVE-2021-21986)

Description

The vSphere Client (HTML5) contains a vulnerability in a vSphere authentication mechanism for the Virtual SAN Health Check, Site Recovery, vSphere Lifecycle Manager, and VMware Cloud Director Availability plug-ins. VMware has evaluated the severity of this issue to be in the Moderate severity range with a maximum CVSSv3 base score of 6.5.

Known Attack Vectors

A malicious actor with network access to port 443 on vCenter Server may perform actions allowed by the impacted plug-ins without authentication.

Workarounds

Please keep in mind that this is a temporary solution only!

A workaround is provided in the following article How to Disable VMware Plugins in vCenter Server (83829)

Resolution

For vCenter Server 7.0, patch to fixed version 7.0 U2b. Download and release note links will be provided below

For vCenter Server 6.7, patch to fixed version 6.7 U3n .  Download and release note links will be provided below

For vCenter Server 6.5, patch to fixed version 6.5 U3p. Download and release nots links will be provided below.

For Cloud Foundation (vCenter Server) 4.x, apply fixed version 4.2.1. Download and release note links will be provided below.

For Cloud Foundation (vCenter Server) 3.x, apply fixed version 3.10.2.1. Download and release note links will be provided below

References

Fixed Version(s) and Release Notes:

vCenter Server 7.0 U2b
Downloads and Documentation:
https://my.vmware.com/en/web/vmware/downloads/info/slug/datacenter_cloud_infrastructure/vmware_vsphere/7_0
https://docs.vmware.com/en/VMware-vSphere/7.0/rn/vsphere-vcenter-server-70u2b-release-notes.html

vCenter Server 6.7 U3n
Downloads and Documentation:
https://my.vmware.com/en/web/vmware/downloads/info/slug/datacenter_cloud_infrastructure/vmware_vsphere/6_7
https://docs.vmware.com/en/VMware-vSphere/6.7/rn/vsphere-vcenter-server-67u3n-release-notes.html

vCenter Server 6.5 U3p
Downloads and Documentation:
https://my.vmware.com/en/web/vmware/downloads/info/slug/datacenter_cloud_infrastructure/vmware_vsphere/6_5
https://docs.vmware.com/en/VMware-vSphere/6.5/rn/vsphere-vcenter-server-65u3p-release-notes.html

VMware vCloud Foundation 4.2.1
Downloads and Documentation:
https://my.vmware.com/en/web/vmware/downloads/details?downloadGroup=VCF421&productId=1121&rPId=67576
https://docs.vmware.com/en/VMware-Cloud-Foundation/4.2.1/rn/VMware-Cloud-Foundation-421-Release-Notes.html

VMware vCloud Foundation 3.10.2.1
Downloads and Documentation:
https://docs.vmware.com/en/VMware-Cloud-Foundation/3.10.2/rn/VMware-Cloud-Foundation-3102-Release-Notes.html#3.10.2.1

Link to official advisory

VMSA-2021-0010 (vmware.com)

Thanks for reading